Switchbacks Forums
April 19, 2014, 10:52:32 pm *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Northwest Trails v1.79 now available (December 12, 2013)
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Fixed a mail issue with data submissions (I think!)  (Read 2743 times)
0 Members and 1 Guest are viewing this topic.
Moun10Bike
Switchbacks.com Guy
Administrator
Expeditionist
*****

Karma: +15/-0
Posts: 270


stanley_jon@hotmail.com
View Profile WWW Email
« on: December 31, 2009, 05:27:41 pm »

One of our users uncovered an email issue that I tracked down and (I think) fixed today.  If you have uploaded data in the past and received a message stating that there had been an SMTP error and that email notification had failed but upload had likely succeeded, you probably were a victim of this same bug.  It occurred when you elected to not receive email confirmation of your upload and used a Hotmail account (or account from another large email provider) for your user email address in the form.  I always have email sent to me to notify me of submissions, but for uploads where the user didn't want email, I would set the originating email address as that of the user rather than as Switchbacks.com (in order to facility easy contact in case of questions).  The system includes Hotmail and some other large domains on a list of potential spam abuse targets and was seeing this as spam originating from Hotmail.  So, I fixed things to always originate from Switchbacks.com and added the user email address as the "Reply To" address rather than the origin.  Make sense?  Huh?

Anyway, please let me know if you encounter any weirdness going forward.  I've also added error logging to help track down any future issues.
Logged

Jon
Moun10Bike
Switchbacks.com Guy
Administrator
Expeditionist
*****

Karma: +15/-0
Posts: 270


stanley_jon@hotmail.com
View Profile WWW Email
« Reply #1 on: January 01, 2010, 02:25:12 pm »

Well, it looks like I spoke too soon.  Although it was working with my tests, I see that some uploads are still getting the SMTP error (although the uploads themselves are succeeding).  I'll keep trying to track the issue down.
Logged

Jon
The Jester
Adventurer
****

Karma: +3/-0
Posts: 96



View Profile
« Reply #2 on: January 07, 2010, 08:48:57 am »

I just got that error message.  It was on the second file I tried uploading in a short time, if that helps.  My email is with Comcast.
Logged

Beware of Geeks bearing Gadgets!
The Jester
Adventurer
****

Karma: +3/-0
Posts: 96



View Profile
« Reply #3 on: January 07, 2010, 06:24:07 pm »

I got the error again (different file).  This time I hadn't asked for email confirmation.
Logged

Beware of Geeks bearing Gadgets!
Moun10Bike
Switchbacks.com Guy
Administrator
Expeditionist
*****

Karma: +15/-0
Posts: 270


stanley_jon@hotmail.com
View Profile WWW Email
« Reply #4 on: January 07, 2010, 06:40:34 pm »

It appears to be on-again off-again, and then only seems to occur when electing to not have email sent to yourself after a submission.  As I mentioned before, I still have the page send an email to me, and it appears that it is that mail that the server is shutting down for fear of possible spam.  I have had no luck squashing this bug, so I went to Google and have found a horde of topics about this having to do with the fact that this happens on GoDaddy (my web host).  So, I have sent a service request through GoDaddy's help system and will hopefully have a solution.

If no solution is available, then I will rework the error message to say "success" and let the submitter know that it was just the notice to me that failed.
Logged

Jon
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!